TreeEventHandler Class

Beta

Default tree event handler.

Implements

Methods

Name Description
constructor(params: TreeEventHandlerParams): TreeEventHandler    
dispose(): void Disposes tree event handler.  
onCheckboxStateChanged(__namedParameters: object): Subscription | undefined Changes nodes checkbox states.  
onDelayedNodeClick(__namedParameters: object): void Activates node editing if editing parameters is supplied and node is editable.  
onNodeCollapsed(__namedParameters: object): void Collapses node  
onNodeExpanded(__namedParameters: object): void Expands node and starts loading children.  
onSelectionModified(__namedParameters: object): Subscription | undefined Selects and deselects nodes until event is handled, handler is disposed or selection replaced event occurs.  
onSelectionReplaced(__namedParameters: object): Subscription | undefined Replaces currently selected nodes until event is handled, handler is disposed or another selection replaced event occurs.  

Defined in

Last Updated: 05 June, 2020