ConfigurableUiManager Class
Configurable Ui Manager maintains controls, Frontstages, Content Groups, Content Layouts, Tasks and Workflows.
Methods
Name | Description | |
---|---|---|
addFrontstageProvider(frontstageProvider: FrontstageProvider): void Static | Add a Frontstage via a provider into the FrontstageManager. | |
createControl(classId: string, uniqueId: string, options?: any): ConfigurableUiElement | undefined Static | Creates a control registered by calling registerControl. | |
findFrontstageDef(id?: string): FrontstageDef | undefined Static | Finds a FrontstageDef, given its id. | |
getWrapperElement(): HTMLElement Static | Gets the HTML wrapper element for Configurable UI | |
initialize(): void Static | Initializes the ConfigurableUiManager and registers core controls. | |
isControlRegistered(classId: string): boolean Static | Determines if a control has been registered based on its classId. | |
loadContentGroup(groupProps: ContentGroupProps): void Static | Loads a ContentGroup into the ContentGroupManager. | |
loadContentGroups(groupPropsList: ContentGroupProps[]): void Static | Loads one or more ContentGroups into the ContentGroupManager. | |
loadContentLayout(layoutProps: ContentLayoutProps): void Static | Loads a ContentLayout into the ContentLayoutManager. | |
loadContentLayouts(layoutPropsList: ContentLayoutProps[]): void Static | Loads one or more ContentLayouts into the ContentLayoutManager. | |
loadKeyboardShortcuts(shortcutList: KeyboardShortcutProps[]): void Static | Loads one or more Keyboard Shortcuts into the KeyboardShortcutManager. | |
loadTasks(taskPropsList: TaskPropsList): void Static | Loads one or more Tasks into the TaskManager. | |
loadWorkflow(workflowProps: WorkflowProps): void Static | Loads a Workflow into the WorkflowManager. | |
loadWorkflows(workflowPropsList: WorkflowPropsList): void Static | Loads one or more Workflows into the WorkflowManager. | |
registerControl(classId: string, constructor: ConfigurableUiControlConstructor): void Static | Registers a control implementing the ConfigurableUiElement interface. | |
unregisterControl(classId: string): void Static | Unregisters a control that has been registered. |
Defined in
Last Updated: 13 June, 2024