BooleanSyncUiListener<SS> Class

A component that expect its children to be a function that will be passed the current boolValue state.

Extends

Methods

Name Description
constructor(props: BooleanListenerProps): BooleanSyncUiListener    
componentDidMount(): void    
componentWillUnmount(): void    
render(): React.ReactNode    

Inherited methods

Name Inherited from Description
UNSAFE_componentWillMount(): void Optional DeprecatedLifecycle Called immediately before mounting occurs, and before Component#render.
UNSAFE_componentWillReceiveProps(nextProps: Readonly<BooleanListenerProps>, nextContext: any): void Optional DeprecatedLifecycle Called when the component may be receiving new props.
UNSAFE_componentWillUpdate(nextProps: Readonly<BooleanListenerProps>, nextState: Readonly<BooleanListenerState>, nextContext: any): void Optional DeprecatedLifecycle Called immediately before rendering when new props or state is received.
componentDidCatch(error: Error, errorInfo: ErrorInfo): void Optional ComponentLifecycle Catches exceptions generated in descendant components.
componentDidUpdate(prevProps: Readonly<BooleanListenerProps>, prevState: Readonly<BooleanListenerState>, snapshot?: SS): void Optional NewLifecycle Called immediately after updating occurs.
componentWillMount(): void Optional DeprecatedLifecycle Called immediately before mounting occurs, and before Component#render.
componentWillReceiveProps(nextProps: Readonly<BooleanListenerProps>, nextContext: any): void Optional DeprecatedLifecycle Called when the component may be receiving new props.
componentWillUpdate(nextProps: Readonly<BooleanListenerProps>, nextState: Readonly<BooleanListenerState>, nextContext: any): void Optional DeprecatedLifecycle Called immediately before rendering when new props or state is received.
forceUpdate(callback?: () => void): void Component<BooleanListenerProps, BooleanListenerState>  
getSnapshotBeforeUpdate(prevProps: Readonly<BooleanListenerProps>, prevState: Readonly<BooleanListenerState>): SS | null Optional NewLifecycle Runs before React applies the result of render to the document, and
setState<K extends undefined>(state: (prevState: Readonly<BooleanListenerState>, props: Readonly<BooleanListenerProps>) => null | S | object | null | S | object, callback?: () => void): void Component<BooleanListenerProps, BooleanListenerState>  
shouldComponentUpdate(nextProps: Readonly<BooleanListenerProps>, nextState: Readonly<BooleanListenerState>, nextContext: any): boolean Optional ComponentLifecycle Called to determine whether the change in props and state should trigger a re-render.

Inherited properties

Name Type Inherited from Description
context any Component<BooleanListenerProps, BooleanListenerState> If using the new style context, re-declare this in your class to be the
contextType Static undefined | Context<any> Component<BooleanListenerProps, BooleanListenerState> If set, this.context will be set at runtime to the current value of the given Context.
props undefined Component<BooleanListenerProps, BooleanListenerState>  
refs [key: string]: ReactInstance Component<BooleanListenerProps, BooleanListenerState>  

Defined in

Last Updated: 29 April, 2020