ContentModifiersList Interface

Contains various rule attributes that allow modifying returned content.

This is not expected to be used directly - use through either ContentModifier or ContentSpecification.

Properties

Name Type Description
calculatedProperties undefined | CalculatedPropertiesSpecification[] Specifications for including calculated properties  
propertiesDisplay undefined | DEPRECATED_PropertiesDisplaySpecification[] Specifications for customizing property display by hiding / showing them Deprecated  
propertyCategories undefined | PropertyCategorySpecification[] Specifications for custom categories.  
propertyEditors undefined | DEPRECATED_PropertyEditorsSpecification[] Specifications for assigning property editors Deprecated  
propertyOverrides undefined | PropertySpecification[] Specifications for various property overrides.  
relatedProperties undefined | RelatedPropertiesSpecification[] Specifications for including properties of related instances  

Defined in

Last Updated: 29 November, 2022