PropertySpecification Interface

Specification of an ECProperty and its overrides

see More details

Extends

Properties

Name Type Description
name string Name of the ECProperty.  

Inherited properties

Name Type Inherited from Description
categoryId string | CategoryIdentifier PropertyOverrides Identifier of a category that should be used for the property.
doNotHideOtherPropertiesOnDisplayOverride undefined | boolean PropertyOverrides Flag to control behavior of isDisplayed override when it's set to true.
editor undefined | PropertyEditorSpecification PropertyOverrides Custom property editor specification.
isDisplayed undefined | boolean PropertyOverrides Display override.
labelOverride undefined | string PropertyOverrides Label override.
overridesPriority undefined | number PropertyOverrides Priority of the specified overrides.
renderer undefined | CustomRendererSpecification PropertyOverrides Custom property renderer specification.

Defined in

Last Updated: 29 November, 2022