DefaultPropertyCategoryOverride Interface

A rule that allows overriding the default property category.

The default property category is a category that gets assigned to properties that otherwise have no category.

see More details

Extends

Properties

Name Type Description
ruleType DefaultPropertyCategoryOverride Used for serializing to JSON.  
specification PropertyCategorySpecification Specification of the category override  

Inherited properties

Name Type Inherited from Description
onlyIfNotHandled undefined | boolean RuleBase Should this rule should be ignored if there is already an existing
priority undefined | number RuleBase Defines the order in which presentation rules will be evaluated and executed.
requiredSchemas undefined | RequiredSchemaSpecification[] RuleBase Schema requirements for this rule.

Defined in

Last Updated: 29 November, 2022