DEPRECATED_ContentRelatedInstancesSpecification Interface
Deprecated Use ContentRelatedInstancesSpecificationNew. Will be removed in iModel.js 3.0
Extends
Properties
Name | Type | Description | |
---|---|---|---|
instanceFilter | undefined | string | Condition for filtering instances of defined related classes. | |
isRecursive | undefined | boolean | Walks the specified relationships recursively to find related instances. | |
relatedClasses | MultiSchemaClassesSpecification | MultiSchemaClassesSpecification[] | List of related instance ECClass specifications. | |
relationships | MultiSchemaClassesSpecification | MultiSchemaClassesSpecification[] | List of ECRelationship specifications to follow when looking for related instances. | |
requiredDirection | undefined | RelationshipDirection | Direction that will be followed in the relationship select criteria. | |
skipRelatedLevel | undefined | number | Skips defined level of related items and shows next level related items. | |
specType | ContentRelatedInstances | Used for serializing to JSON. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
calculatedProperties | undefined | CalculatedPropertiesSpecification[] | ContentSpecificationBase | Specifications for including calculated properties |
priority | undefined | number | ContentSpecificationBase | Defines the order in which specifications are evaluated and executed. |
propertiesDisplay | undefined | DEPRECATED_PropertiesDisplaySpecification[] | ContentSpecificationBase | Specifications for customizing property display by hiding / showing them |
propertyCategories | undefined | PropertyCategorySpecification[] | ContentSpecificationBase | Specifications for custom categories. |
propertyEditors | undefined | DEPRECATED_PropertyEditorsSpecification[] | ContentSpecificationBase | Specifications for assigning property editors |
propertyOverrides | undefined | PropertySpecification[] | ContentSpecificationBase | Specifications for various property overrides. |
relatedInstances | undefined | RelatedInstanceSpecification[] | ContentSpecificationBase | Specifications for joining related instances |
relatedProperties | undefined | RelatedPropertiesSpecification[] | ContentSpecificationBase | Specifications for including properties of related instances |
showImages | undefined | boolean | ContentSpecificationBase | Should each content record be assigned an image id |
Defined in
- presentation/common/src/presentation-common/rules/content/ContentRelatedInstancesSpecification.ts Line 28
Last Updated: 11 June, 2024