DEPRECATED_RelatedPropertiesSpecification Interface

Deprecated  Use RelatedPropertiesSpecificationNew. Will be removed in iModel.js 3.0

Sub-specification to include additional related instance properties.

Properties

Name Type Description
autoExpand undefined | boolean Should field containing related properties be automatically expanded.  
handleTargetClassPolymorphically undefined | boolean Should the target class specified in DEPRECATED_RelatedPropertiesSpecification.relatedClasses be handled  
isPolymorphic undefined | boolean Should DEPRECATED_RelatedPropertiesSpecification.relationships and DEPRECATED_RelatedPropertiesSpecification.relatedClasses be handled polymorphically. Deprecated  
nestedRelatedProperties undefined | RelatedPropertiesSpecification[] Specifications for nested related properties  
properties RelatedPropertiesSpecialValues | string | PropertySpecification[] A list of property names or specifications that should be included in the content.  
propertyNames string[] | RelatedPropertiesSpecialValues List of names of related class properties that should be included in the content. Deprecated  
relatedClasses MultiSchemaClassesSpecification | MultiSchemaClassesSpecification[] Specifications of related ECClasses.  
relationshipMeaning undefined | RelationshipMeaning Meaning of the relationship which tells how to categorize the related properties.  
relationships MultiSchemaClassesSpecification | MultiSchemaClassesSpecification[] Specifications of ECRelationshipClasses.  
requiredDirection undefined | RelationshipDirection Direction that will be followed in the relationship select criteria.  
skipIfDuplicate undefined | boolean Should this related properties specification be ignored if it duplicates another higher priority specification for the same relationship. Beta  

Defined in

Last Updated: 29 November, 2022