RelatedPropertiesSpecificationNew Interface

Sub-specification to include additional related instance properties.

Properties

Name Type Description
autoExpand undefined | boolean Should field containing related properties be automatically expanded.  
handleTargetClassPolymorphically undefined | boolean Should the target class specified in RelatedPropertiesSpecificationNew.propertiesSource be handled  
properties RelatedPropertiesSpecialValues | string | PropertySpecification[] A list of property names or specifications that should be included in the content.  
propertiesSource RelationshipPathSpecification Relationship path from content class to properties' class.  
relationshipMeaning undefined | RelationshipMeaning Meaning of the relationship which tells how to categorize the related properties.  
skipIfDuplicate undefined | boolean Should this related properties specification be ignored if it duplicates another higher priority specification for the same relationship. Beta  

Defined in

Last Updated: 29 November, 2022