RelatedPropertiesSpecificationNew Interface

Beta

Sub-specification to include additional related instance properties.

Properties

Name Type Description
autoExpand undefined | boolean Should field containing related properties be automatically expanded.  
handleTargetClassPolymorphically undefined | boolean Should the target class specified in RelatedPropertiesSpecificationNew.propertiesSource be handled  
properties Array<string | PropertySpecification> | RelatedPropertiesSpecialValues A list of property names or specifications that should be included in the content.  
propertiesSource RelationshipPathSpecification Relationship path from content class to properties' class.  
relationshipMeaning undefined | RelationshipMeaning Meaning of the relationship.  

Defined in

Last Updated: 05 June, 2020