Backstage<SS> Class

Backstage React component.

Extends

Methods

Name Description
constructor(props: BackstageProps): Backstage    
componentDidMount(): void    
componentDidUpdate(prevProps: BackstageProps): void    
componentWillUnmount(): void    
render(): React.ReactNode    
getBackstageToggleCommand(overrideIconSpec?: IconSpec): CommandItemDef Static Get CommandItemDef that will toggle display of Backstage and allow iconSpec to be overridden  
hide(): void Static Hides the Backstage  
show(): void Static Shows the Backstage  

Inherited methods

Name Inherited from Description
UNSAFE_componentWillMount(): void Optional DeprecatedLifecycle Called immediately before mounting occurs, and before Component#render.
UNSAFE_componentWillReceiveProps(nextProps: Readonly<BackstageProps>, nextContext: any): void Optional DeprecatedLifecycle Called when the component may be receiving new props.
UNSAFE_componentWillUpdate(nextProps: Readonly<BackstageProps>, nextState: Readonly<BackstageState>, nextContext: any): void Optional DeprecatedLifecycle Called immediately before rendering when new props or state is received.
componentDidCatch(error: Error, errorInfo: ErrorInfo): void Optional ComponentLifecycle Catches exceptions generated in descendant components.
componentWillMount(): void Optional DeprecatedLifecycle Called immediately before mounting occurs, and before Component#render.
componentWillReceiveProps(nextProps: Readonly<BackstageProps>, nextContext: any): void Optional DeprecatedLifecycle Called when the component may be receiving new props.
componentWillUpdate(nextProps: Readonly<BackstageProps>, nextState: Readonly<BackstageState>, nextContext: any): void Optional DeprecatedLifecycle Called immediately before rendering when new props or state is received.
forceUpdate(callback?: () => void): void Component<BackstageProps, BackstageState>  
getSnapshotBeforeUpdate(prevProps: Readonly<BackstageProps>, prevState: Readonly<BackstageState>): SS | null Optional NewLifecycle Runs before React applies the result of render to the document, and
setState<K extends undefined>(state: (prevState: Readonly<BackstageState>, props: Readonly<BackstageProps>) => null | S | object | null | S | object, callback?: () => void): void Component<BackstageProps, BackstageState>  
shouldComponentUpdate(nextProps: Readonly<BackstageProps>, nextState: Readonly<BackstageState>, nextContext: any): boolean Optional ComponentLifecycle Called to determine whether the change in props and state should trigger a re-render.

Properties

Name Type Description
backstageToggleCommand Accessor StaticReadOnly CommandItemDef Command that toggles the Backstage  
isBackstageVisible Static boolean    
onBackstageEvent Static BackstageEvent    

Inherited properties

Name Type Inherited from Description
context any Component<BackstageProps, BackstageState> If using the new style context, re-declare this in your class to be the
contextType Static undefined | Context<any> Component<BackstageProps, BackstageState> If set, this.context will be set at runtime to the current value of the given Context.
props undefined Component<BackstageProps, BackstageState>  
refs [key: string]: ReactInstance Component<BackstageProps, BackstageState>  

Defined in

Last Updated: 05 June, 2020