CheckpointConnection Class
An IModelConnection to a checkpoint of an iModel, hosted on a remote backend over RPC. Due to the nature of RPC requests, the backend servicing this connection may change over time, and there may even be more than one backend at servicing requests at the same time. For this reason, this type of connection may only be used with Checkpoint iModels that are guaranteed to be the same on every backend. Obviously Checkpoint iModels only allow readonly access.
Extends
Extended by
Methods
Name | Description | |
---|---|---|
close(): Promise<void> | Close this CheckpointConnection | |
isCheckpointConnection(): this is CheckpointConnection | Type guard for instanceof CheckpointConnection | |
open(contextId: string, iModelId: string, openMode: OpenMode = OpenMode.Readonly, version: IModelVersion = ...): Promise<CheckpointConnection> Static | Open a CheckpointConnection to a checkpoint of an iModel. | Deprecated |
openRemote(contextId: string, iModelId: string, version: IModelVersion = ...): Promise<CheckpointConnection> Static | Open a readonly IModelConnection to an iModel over RPC. |
Inherited methods
Name | Inherited from | Description |
---|---|---|
cartographicToSpatial(cartographic: Cartographic, result?: Point3d): Promise<Point3d> | IModelConnection | Convert a Cartographic to a point in this iModel's Spatial coordinates using the Geographic location services for this IModelConnection or ecefLocation. |
cartographicToSpatialFromEcef(cartographic: Cartographic, result?: Point3d): Point3d | IModelConnection | Convert a Cartographic to a point in this iModel's Spatial coordinates using its ecefLocation. |
cartographicToSpatialFromGcs(cartographic: Cartographic, result?: Point3d): Promise<Point3d> | IModelConnection | Convert a Cartographic to a point in this iModel's Spatial coordinates using the Geographic location services for this IModelConnection. |
ecefToSpatial(ecef: Readonly<WritableXYAndZ>, result?: Point3d): Point3d | IModelConnection | Convert a point in ECEF coordinates to a point in this iModel's Spatial coordinates using its IModelConnection.ecefLocation. |
expandDisplayedExtents(range: Range3d): void | IModelConnection | Expand this iModel's IModelConnection.displayedExtents to include the specified range. |
findClassFor<T extends undefined>(className: string, defaultClass: undefined | T): Promise<undefined | T> | IModelConnection | Find the first registered base class of the given EntityState className. |
getEcefTransform(): Transform | IModelConnection | Get the Transform from this iModel's Spatial coordinates to ECEF coordinates using its ecefLocation. |
getGeometryContainment(requestProps: GeometryContainmentRequestProps): Promise<GeometryContainmentResponseProps> | IModelConnection | Request element clip containment status from the backend. |
getGeometrySummary(requestProps: GeometrySummaryRequestProps): Promise<string> | IModelConnection | Obtain a summary of the geometry belonging to one or more GeometricElements suitable for debugging and diagnostics. |
getMassProperties(requestProps: MassPropertiesRequestProps): Promise<MassPropertiesResponseProps> | IModelConnection | Request element mass properties from the backend. |
getRpcProps(): IModelRpcProps | IModelConnection | Return a token for RPC operations. |
getTextureImage(textureLoadProps: TextureLoadProps): Promise<undefined | Uint8Array> | IModelConnection | Request a named texture image from the backend. |
IModelConnection | Request a tooltip from the backend. | |
isBlankConnection(): this is BlankConnection | IModelConnection | Type guard for instanceof BlankConnection |
isBriefcaseConnection(): this is BriefcaseConnection | IModelConnection | Type guard for instanceof BriefcaseConnection |
isRemoteBriefcaseConnection(): this is RemoteBriefcaseConnection | IModelConnection | Type guard for instanceof RemoteBriefcaseConnection |
isSnapshotConnection(): this is SnapshotConnection | IModelConnection | Type guard for instanceof SnapshotConnection |
loadFontMap(): Promise<FontMap> | IModelConnection | Load the FontMap for this IModelConnection. |
query(ecsql: string, bindings?: object | any[], limitRows?: number, quota?: QueryQuota, priority?: QueryPriority, abbreviateBlobs?: boolean): AsyncIterableIterator<any> | IModelConnection | Execute a query and stream its results |
queryEntityIds(params: EntityQueryParams): Promise<Id64Set> | IModelConnection | Query for a set of element ids that satisfy the supplied query params |
queryRowCount(ecsql: string, bindings?: object | any[]): Promise<number> | IModelConnection | Compute number of rows that would be returned by the ECSQL. |
restartQuery(token: string, ecsql: string, bindings?: object | any[], limitRows?: number, quota?: QueryQuota, priority?: QueryPriority): AsyncIterableIterator<any> | IModelConnection | Execute a query and stream its results |
setEcefLocation(ecef: EcefLocationProps): void | IModelConnection | Set the EcefLocation for this iModel. |
setGeographicCoordinateSystem(geoCRS: GeographicCRSProps): void | IModelConnection | Sets the geographic coordinate reference system from GeographicCRSProps. |
spatialToCartographic(spatial: Readonly<WritableXYAndZ>, result?: Cartographic): Promise<Cartographic> | IModelConnection | Convert a point in this iModel's Spatial coordinates to a Cartographic using the Geographic location services for this IModelConnection or ecefLocation. |
spatialToCartographicFromEcef(spatial: Readonly<WritableXYAndZ>, result?: Cartographic): Cartographic | IModelConnection | Convert a point in this iModel's Spatial coordinates to a Cartographic using its ecefLocation. |
spatialToCartographicFromGcs(spatial: Readonly<WritableXYAndZ>, result?: Cartographic): Promise<Cartographic> | IModelConnection | Convert a point in this iModel's Spatial coordinates to a Cartographic using the Geographic location services for this IModelConnection. |
spatialToEcef(spatial: Readonly<WritableXYAndZ>, result?: Point3d): Point3d | IModelConnection | Convert a point in this iModel's Spatial coordinates to an ECEF point using its ecefLocation. |
getDefaultSubCategoryId(categoryId: string): string Static | IModelConnection | Get the default subCategoryId for the supplied categoryId |
Properties
Name | Type | Description | |
---|---|---|---|
_isClosed Protected | undefined | boolean | ||
contextId Accessor ReadOnly | string | The Guid that identifies the context that owns this iModel. | |
iModelId Accessor ReadOnly | string | The Guid that identifies this iModel. | |
isClosed Accessor ReadOnly | boolean | Returns true if CheckpointConnection.close has already been called. |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
changeset | ChangesetIdWithIndex | IModelConnection | |
changeSetId Accessor ReadOnly | string | IModelConnection | The Id of the last changeset that was applied to this iModel. |
codeSpecs Readonly | IModelConnection.CodeSpecs | IModelConnection | The CodeSpecs in this IModelConnection. |
connectionTimeout Static | number | IModelConnection | The maximum time (in milliseconds) to wait before timing out the request to open a connection to a new iModel |
dictionaryId StaticReadonly | string | IModelConnection | The Id of the dictionary model. |
displayedExtents Readonly | Range3d | IModelConnection | The displayed extents of this iModel, initialized to IModel.projectExtents. |
ecefLocation Accessor | undefined | EcefLocation | IModelConnection | The EcefLocation of the iModel in Earth Centered Earth Fixed coordinates. |
elements Readonly | IModelConnection.Elements | IModelConnection | The ElementStates in this IModelConnection. |
fontMap | undefined | FontMap | IModelConnection | The font map for this IModelConnection. |
geographicCoordinateSystem Accessor | undefined | GeographicCRS | IModelConnection | The geographic coordinate reference system of the iModel. |
globalOrigin Accessor | Point3d | IModelConnection | An offset to be applied to all spatial coordinates. |
hilited Readonly | HiliteSet | IModelConnection | The set of currently hilited elements for this IModelConnection. |
isBlank Accessor ReadOnly | boolean | IModelConnection | True if this is a Blank Connection. |
isBriefcase Accessor ReadOnly | boolean | IModelConnection | Returns true if this is a briefcase copy of an iModel that is synchronized with iModelHub. |
isGeoLocated Accessor ReadOnly | boolean | IModelConnection | True if this iModel has an EcefLocation. |
isOpen Accessor ReadOnly | boolean | IModelConnection | Check if the IModelConnection is open (i.e. it has a connection to a backend server). Returns false for BlankConnection instances and after IModelConnection.close has been called. |
isReadonly Accessor ReadOnly | boolean | IModelConnection | Check the IModelConnection.openMode of this IModelConnection to see if it was opened read-only. |
isSnapshot Accessor ReadOnly | boolean | IModelConnection | Returns true if this is a snapshot iModel. |
key Accessor ReadOnly | string | IModelConnection | Get the key that was used to open this iModel. This is the value used for Rpc and Ipc communications. |
models Readonly | IModelConnection.Models | IModelConnection | The ModelStates in this IModelConnection. |
name Accessor | string | IModelConnection | Name of the iModel |
onClose Readonly | BeEvent<(_imodel: IModelConnection) => void> | IModelConnection | Event called immediately before this IModelConnection is closed. |
onClose StaticReadonly | BeEvent<(_imodel: IModelConnection) => void> | IModelConnection | Event called immediately before any IModelConnection is closed. |
onEcefLocationChanged Readonly | BeEvent<(previousLocation: undefined | EcefLocation) => void> | IModelConnection | Event raised after IModelConnection.ecefLocation changes. |
onGeographicCoordinateSystemChanged Readonly | BeEvent<(previousGCS: undefined | GeographicCRS) => void> | IModelConnection | Event raised after IModelConnection.geographicCoordinateSystem changes. |
onGlobalOriginChanged Readonly | BeEvent<(previousOrigin: Point3d) => void> | IModelConnection | Event raised after IModelConnection.globalOrigin changes. |
onNameChanged Readonly | BeEvent<(previousName: string) => void> | IModelConnection | Event raised after IModelConnection.name changes. |
onOpen StaticReadonly | BeEvent<(_imodel: IModelConnection) => void> | IModelConnection | Event called immediately after any IModelConnection is opened. |
onProjectExtentsChanged Readonly | BeEvent<(previousExtents: Range3d) => void> | IModelConnection | Event raised after IModelConnection.projectExtents changes. |
onRootSubjectChanged Readonly | BeEvent<(previousSubject: RootSubjectProps) => void> | IModelConnection | Event raised after IModelConnection.rootSubject changes. |
openMode Readonly | OpenMode | IModelConnection | The OpenMode used for this IModel. |
projectExtents Accessor | Range3d | IModelConnection | The volume, in spatial coordinates, inside which the entire project is contained. |
repositoryModelId StaticReadonly | string | IModelConnection | The Id of the repository model. |
rootSubject Accessor | RootSubjectProps | IModelConnection | The name and description of the root subject of this iModel |
rootSubjectId StaticReadonly | string | IModelConnection | The Id of the root subject element. |
routingContext | IModelRoutingContext | IModelConnection | The RPC routing for this connection. |
selectionSet Readonly | SelectionSet | IModelConnection | The set of currently selected elements for this IModelConnection. |
tiles Readonly | Tiles | IModelConnection | The set of Tiles for this IModelConnection. |
transientIds Readonly | TransientIdSequence | IModelConnection | Generator for unique Ids of transient graphics for this IModelConnection. |
views Readonly | IModelConnection.Views | IModelConnection | The ViewStates in this IModelConnection. |
Defined in
Last Updated: 11 June, 2024