RemoteBriefcaseConnection Class

Deprecated  use BriefcaseConnection with an IpcApp

Extends

Methods

Name Description
pullAndMergeChanges(): Promise<void> Pull and merge new server changes  
pushChanges(description: string): Promise<void> Push local changes to the server  
saveChanges(description?: string): Promise<void> Commit pending changes to this iModel  
updateProjectExtents(newExtents: Range3d): Promise<void> Update the project extents of this iModel.  
open(contextId: string, iModelId: string, openMode: OpenMode = OpenMode.Readonly, version: IModelVersion = ...): Promise<RemoteBriefcaseConnection> Static Open a CheckpointConnection to a checkpoint of an iModel.  

Inherited methods

Name Inherited from Description
cartographicToSpatial(cartographic: Cartographic, result?: Point3d): Promise<Point3d> CheckpointConnection Convert a Cartographic to a point in this iModel's Spatial coordinates using the Geographic location services for this IModelConnection or ecefLocation.
cartographicToSpatialFromEcef(cartographic: Cartographic, result?: Point3d): Point3d CheckpointConnection Convert a Cartographic to a point in this iModel's Spatial coordinates using its ecefLocation.
cartographicToSpatialFromGcs(cartographic: Cartographic, result?: Point3d): Promise<Point3d> CheckpointConnection Convert a Cartographic to a point in this iModel's Spatial coordinates using the Geographic location services for this IModelConnection.
close(): Promise<void> CheckpointConnection Close this CheckpointConnection
ecefToSpatial(ecef: Readonly<WritableXYAndZ>, result?: Point3d): Point3d CheckpointConnection Convert a point in ECEF coordinates to a point in this iModel's Spatial coordinates using its CheckpointConnection.ecefLocation.
expandDisplayedExtents(range: Range3d): void CheckpointConnection Expand this iModel's CheckpointConnection.displayedExtents to include the specified range.
findClassFor<T extends undefined>(className: string, defaultClass: undefined | T): Promise<undefined | T> CheckpointConnection Find the first registered base class of the given EntityState className.
getEcefTransform(): Transform CheckpointConnection Get the Transform from this iModel's Spatial coordinates to ECEF coordinates using its ecefLocation.
getGeometryContainment(requestProps: GeometryContainmentRequestProps): Promise<GeometryContainmentResponseProps> CheckpointConnection Request element clip containment status from the backend.
getGeometrySummary(requestProps: GeometrySummaryRequestProps): Promise<string> CheckpointConnection Obtain a summary of the geometry belonging to one or more GeometricElements suitable for debugging and diagnostics.
getMassProperties(requestProps: MassPropertiesRequestProps): Promise<MassPropertiesResponseProps> CheckpointConnection Request element mass properties from the backend.
getRpcProps(): IModelRpcProps CheckpointConnection Return a token for RPC operations.
getTextureImage(textureLoadProps: TextureLoadProps): Promise<undefined | Uint8Array> CheckpointConnection Request a named texture image from the backend.
getToolTipMessage(id: string): Promise<string[]> CheckpointConnection Request a tooltip from the backend.
isBlankConnection(): this is BlankConnection CheckpointConnection Type guard for instanceof BlankConnection
isBriefcaseConnection(): this is BriefcaseConnection CheckpointConnection Type guard for instanceof BriefcaseConnection
isCheckpointConnection(): this is CheckpointConnection CheckpointConnection Type guard for instanceof CheckpointConnection
isRemoteBriefcaseConnection(): this is RemoteBriefcaseConnection CheckpointConnection Type guard for instanceof RemoteBriefcaseConnection
isSnapshotConnection(): this is SnapshotConnection CheckpointConnection Type guard for instanceof SnapshotConnection
loadFontMap(): Promise<FontMap> CheckpointConnection Load the FontMap for this IModelConnection.
query(ecsql: string, bindings?: object | any[], limitRows?: number, quota?: QueryQuota, priority?: QueryPriority, abbreviateBlobs?: boolean): AsyncIterableIterator<any> CheckpointConnection Execute a query and stream its results
queryEntityIds(params: EntityQueryParams): Promise<Id64Set> CheckpointConnection Query for a set of element ids that satisfy the supplied query params
queryRowCount(ecsql: string, bindings?: object | any[]): Promise<number> CheckpointConnection Compute number of rows that would be returned by the ECSQL.
restartQuery(token: string, ecsql: string, bindings?: object | any[], limitRows?: number, quota?: QueryQuota, priority?: QueryPriority): AsyncIterableIterator<any> CheckpointConnection Execute a query and stream its results
setEcefLocation(ecef: EcefLocationProps): void CheckpointConnection Set the EcefLocation for this iModel.
setGeographicCoordinateSystem(geoCRS: GeographicCRSProps): void CheckpointConnection Sets the geographic coordinate reference system from GeographicCRSProps.
spatialToCartographic(spatial: Readonly<WritableXYAndZ>, result?: Cartographic): Promise<Cartographic> CheckpointConnection Convert a point in this iModel's Spatial coordinates to a Cartographic using the Geographic location services for this IModelConnection or ecefLocation.
spatialToCartographicFromEcef(spatial: Readonly<WritableXYAndZ>, result?: Cartographic): Cartographic CheckpointConnection Convert a point in this iModel's Spatial coordinates to a Cartographic using its ecefLocation.
spatialToCartographicFromGcs(spatial: Readonly<WritableXYAndZ>, result?: Cartographic): Promise<Cartographic> CheckpointConnection Convert a point in this iModel's Spatial coordinates to a Cartographic using the Geographic location services for this IModelConnection.
spatialToEcef(spatial: Readonly<WritableXYAndZ>, result?: Point3d): Point3d CheckpointConnection Convert a point in this iModel's Spatial coordinates to an ECEF point using its ecefLocation.
getDefaultSubCategoryId(categoryId: string): string Static CheckpointConnection Get the default subCategoryId for the supplied categoryId
openRemote(contextId: string, iModelId: string, version: IModelVersion = ...): Promise<CheckpointConnection> Static CheckpointConnection Open a readonly IModelConnection to an iModel over RPC.

Inherited properties

Name Type Inherited from Description
_isClosed Protected undefined | boolean CheckpointConnection  
changeset ChangesetIdWithIndex CheckpointConnection  
changeSetId Accessor ReadOnly string CheckpointConnection The Id of the last changeset that was applied to this iModel.
codeSpecs Readonly IModelConnection.CodeSpecs CheckpointConnection The CodeSpecs in this IModelConnection.
connectionTimeout Static number CheckpointConnection The maximum time (in milliseconds) to wait before timing out the request to open a connection to a new iModel
contextId Accessor ReadOnly string CheckpointConnection The Guid that identifies the context that owns this iModel.
dictionaryId StaticReadonly string CheckpointConnection The Id of the dictionary model.
displayedExtents Readonly Range3d CheckpointConnection The displayed extents of this iModel, initialized to IModel.projectExtents.
ecefLocation Accessor undefined | EcefLocation CheckpointConnection The EcefLocation of the iModel in Earth Centered Earth Fixed coordinates.
elements Readonly IModelConnection.Elements CheckpointConnection The ElementStates in this IModelConnection.
fontMap undefined | FontMap CheckpointConnection The font map for this IModelConnection.
geographicCoordinateSystem Accessor undefined | GeographicCRS CheckpointConnection The geographic coordinate reference system of the iModel.
globalOrigin Accessor Point3d CheckpointConnection An offset to be applied to all spatial coordinates.
hilited Readonly HiliteSet CheckpointConnection The set of currently hilited elements for this IModelConnection.
iModelId Accessor ReadOnly string CheckpointConnection The Guid that identifies this iModel.
isBlank Accessor ReadOnly boolean CheckpointConnection True if this is a Blank Connection.
isBriefcase Accessor ReadOnly boolean CheckpointConnection Returns true if this is a briefcase copy of an iModel that is synchronized with iModelHub.
isClosed Accessor ReadOnly boolean CheckpointConnection Returns true if CheckpointConnection.close has already been called.
isGeoLocated Accessor ReadOnly boolean CheckpointConnection True if this iModel has an EcefLocation.
isOpen Accessor ReadOnly boolean CheckpointConnection Check if the IModelConnection is open (i.e. it has a connection to a backend server).
Returns false for BlankConnection instances and after IModelConnection.close has been called.
isReadonly Accessor ReadOnly boolean CheckpointConnection Check the CheckpointConnection.openMode of this IModelConnection to see if it was opened read-only.
isSnapshot Accessor ReadOnly boolean CheckpointConnection Returns true if this is a snapshot iModel.
key Accessor ReadOnly string CheckpointConnection Get the key that was used to open this iModel. This is the value used for Rpc and Ipc communications.
models Readonly IModelConnection.Models CheckpointConnection The ModelStates in this IModelConnection.
name Accessor string CheckpointConnection Name of the iModel
onClose Readonly BeEvent<(_imodel: IModelConnection) => void> CheckpointConnection Event called immediately before this IModelConnection is closed.
onClose StaticReadonly BeEvent<(_imodel: IModelConnection) => void> CheckpointConnection Event called immediately before any IModelConnection is closed.
onEcefLocationChanged Readonly BeEvent<(previousLocation: undefined | EcefLocation) => void> CheckpointConnection Event raised after CheckpointConnection.ecefLocation changes.
onGeographicCoordinateSystemChanged Readonly BeEvent<(previousGCS: undefined | GeographicCRS) => void> CheckpointConnection Event raised after CheckpointConnection.geographicCoordinateSystem changes.
onGlobalOriginChanged Readonly BeEvent<(previousOrigin: Point3d) => void> CheckpointConnection Event raised after CheckpointConnection.globalOrigin changes.
onNameChanged Readonly BeEvent<(previousName: string) => void> CheckpointConnection Event raised after CheckpointConnection.name changes.
onOpen StaticReadonly BeEvent<(_imodel: IModelConnection) => void> CheckpointConnection Event called immediately after any IModelConnection is opened.
onProjectExtentsChanged Readonly BeEvent<(previousExtents: Range3d) => void> CheckpointConnection Event raised after CheckpointConnection.projectExtents changes.
onRootSubjectChanged Readonly BeEvent<(previousSubject: RootSubjectProps) => void> CheckpointConnection Event raised after CheckpointConnection.rootSubject changes.
openMode Readonly OpenMode CheckpointConnection The OpenMode used for this IModel.
projectExtents Accessor Range3d CheckpointConnection The volume, in spatial coordinates, inside which the entire project is contained.
repositoryModelId StaticReadonly string CheckpointConnection The Id of the repository model.
rootSubject Accessor RootSubjectProps CheckpointConnection The name and description of the root subject of this iModel
rootSubjectId StaticReadonly string CheckpointConnection The Id of the root subject element.
routingContext IModelRoutingContext CheckpointConnection The RPC routing for this connection.
selectionSet Readonly SelectionSet CheckpointConnection The set of currently selected elements for this IModelConnection.
tiles Readonly Tiles CheckpointConnection The set of Tiles for this IModelConnection.
transientIds Readonly TransientIdSequence CheckpointConnection Generator for unique Ids of transient graphics for this IModelConnection.
views Readonly IModelConnection.Views CheckpointConnection The ViewStates in this IModelConnection.

Defined in

Last Updated: 29 November, 2022