ViewState2d Class
Defines the state of a view of a single 2d model.
Extends
Extended by
Implements
Methods
Name | Description | |
---|---|---|
constructor(props: ViewDefinition2dProps, iModel: IModelConnection, categories: CategorySelectorState, displayStyle: DisplayStyle2dState): ViewState2d | ||
allow3dManipulations(): boolean | ||
computeFitRange(): Range3d | ||
createAuxCoordSystem(acsName: string): AuxCoordSystemState | ||
forEachModel(func: (model: GeometricModelState) => void): void | ||
getExtents(): Vector3d | ||
getOrigin(): Point3d | ||
getRotation(): Matrix3d | ||
getViewedExtents(): AxisAlignedBox3d | ||
getViewedModel(): GeometricModel2dState | undefined | Return the model for this 2d view. | |
load(): Promise<void> | ||
onRenderFrame(_viewport: Viewport): void | ||
setExtents(delta: XAndY): void | ||
setOrigin(origin: XAndY): void | ||
setRotation(rot: Matrix3d): void | ||
toJSON(): ViewDefinition2dProps | ||
viewsModel(modelId: Id64String): boolean |
Inherited methods
Name | Inherited from | Description |
---|---|---|
calculateFocusCorners(): Point3d[] | ViewState | |
calculateFrustum(result?: Frustum): Frustum | undefined | ViewState | Calculate the world coordinate Frustum from the parameters of this ViewState. |
clone(iModel?: IModelConnection): this | EntityState | Make an independent copy of this EntityState |
equals(other: this): boolean | ViewState | Determine whether this ViewState exactly matches another. |
getAspectRatio(): number | ViewState | Get the aspect ratio (width/height) of this view |
getAspectRatioSkew(): number | ViewState | Get the aspect ratio skew (x/y, usually 1.0) that is used to exaggerate the y axis of the view. |
getAuxiliaryCoordinateSystemId(): Id64String | ViewState | Get the Id of the auxiliary coordinate system for this ViewState |
getCenter(result?: Primitives.Point3d): Point3d | ViewState | Get the point at the geometric center of the view. |
getDetails(): any | ViewState | |
getGridOrientation(): GridOrientationType | ViewState | Get the grid settings for this view |
getGridSettings(vp: Viewport, origin: Point3d, rMatrix: Matrix3d, orientation: GridOrientationType): void | ViewState | Populate the given origin and rotation with information from the grid settings from the grid orientation. |
getGridSpacing(): XAndY | ViewState | |
getGridsPerRef(): number | ViewState | |
getSubCategoryOverride(id: Id64String): SubCategoryOverride | undefined | ViewState | Query the symbology overrides applied to geometry belonging to a specific subcategory when rendered using this ViewState. |
getTargetPoint(result?: Primitives.Point3d): Point3d | ViewState | Get the target point of the view. |
getViewClip(): ClipVector | undefined | ViewState | Get the clipping volume for this view, if defined |
getXVector(result?: Vector3d): Vector3d | ViewState | Get the unit vector that points in the view X (left-to-right) direction. |
getYVector(result?: Vector3d): Vector3d | ViewState | Get the unit vector that points in the view Y (bottom-to-top) direction. |
getZVector(result?: Vector3d): Vector3d | ViewState | Get the unit vector that points in the view Z (front-to-back) direction. |
is2d(): this is ViewState2d | ViewState | Returns true if this ViewState is-a ViewState2d |
is3d(): this is ViewState3d | ViewState | Returns true if this ViewState is-a ViewState3d |
isCameraEnabled(): this is ViewState3d | ViewState | Returns true if this ViewState is-a ViewState3d with the camera currently on. |
isDrawingView(): this is DrawingViewState | ViewState | Returns true if this ViewState is-a DrawingViewState |
isSpatialView(): this is SpatialViewState | ViewState | Returns true if this ViewState is-a SpatialViewState |
lookAtViewAlignedVolume(volume: Range3d, aspect?: number, margin?: MarginPercent): void | ViewState | Look at a volume of space defined by a range in view local coordinates, keeping its current rotation. |
lookAtVolume(volume: LowAndHighXYZ | LowAndHighXY, aspect?: number, margin?: MarginPercent): void | ViewState | Change the volume that this view displays, keeping its current rotation. |
resetExtentLimits(): void | ViewState | Resets the largest and smallest values allowed for the extents of this ViewState to their default values. |
setAspectRatioSkew(val: number): void | ViewState | Set the aspect ratio skew (x/y) for this view. |
setAuxiliaryCoordinateSystem(acs?: AuxCoordSystemState): void | ViewState | Set or clear the AuxiliaryCoordinateSystem for this view. |
setCategorySelector(categories: CategorySelectorState): void | ViewState | Set the CategorySelector for this view. |
setCenter(center: Point3d): void | ViewState | set the center of this view to a new position. |
setDisplayStyle(style: DisplayStyleState): void | ViewState | |
setGridSettings(orientation: GridOrientationType, spacing: Point2d, gridsPerRef: number): void | ViewState | Set the grid settings for this view |
setRotationAboutPoint(rotation: Matrix3d, point?: Primitives.Point3d): void | ViewState | Set the rotation of this ViewState to the supplied rotation, by rotating it about a point. |
setStandardRotation(id: StandardViewId): void | ViewState | Orient this view to one of the StandardView rotations. |
setViewClip(clip?: ClipVector): void | ViewState | Set or clear the clipping volume for this view. |
setupFromFrustum(inFrustum: Frustum): ViewStatus | ViewState | Initialize the origin, extents, and rotation from an existing Frustum |
viewsCategory(id: Id64String): boolean | ViewState | Determine whether the specified Category is displayed in this view |
createFromProps(_props: ViewStateProps, _iModel: IModelConnection): ViewState | undefined Static | ViewState | Create a new ViewState object from a set of properties. |
Properties
Name | Type | Description | |
---|---|---|---|
angle | Angle | ||
baseModelId | Id64String | ||
delta | Point2d | ||
details Accessor ReadOnly | ViewDetails | Provides access to optional detail settings for this view. | Beta |
origin | Point2d |
Inherited properties
Name | Type | Inherited from | Description |
---|---|---|---|
analysisStyle Accessor ReadOnly | AnalysisStyle | undefined | ViewState | Get the AnalysisDisplayProperties from the displayStyle of this ViewState. |
auxiliaryCoordinateSystem Accessor ReadOnly | AuxCoordSystemState | ViewState | get the auxiliary coordinate system state object for this ViewState. |
backgroundColor Accessor ReadOnly | ColorDef | ViewState | Get this view's background color. |
categorySelector | CategorySelectorState | ViewState | Selects the categories that are display by this ViewState. |
classFullName Accessor StaticReadOnly | string | EntityState | Get full BIS class name of this Entity in the form "SchemaName:ClassName". |
classFullName | string | EntityState | The full class name in the form "schema:class". |
className Accessor ReadOnly | string | EntityState | The name of the BIS class associated with this class. |
code | Code | ElementState | The Code for this element |
defaultExtentLimits Accessor ReadOnly | ExtentLimits | ViewState | Returns the default extent limits for this ViewState. These limits are used if the ViewState.extentLimits have not been explicitly overridden. |
description | undefined | string | ViewState | |
displayStyle | DisplayStyleState | ViewState | Selects the styling parameters for this this ViewState. |
extentLimits Accessor | ExtentLimits | ViewState | Get or set the largest and smallest values allowed for the extents for this ViewState The default limits vary based on the type of view: - Spatial view extents cannot exceed the diameter of the earth. - Drawing view extents cannot exceed twice the longest axis of the drawing model's range. - Sheet view extents cannot exceed ten times the paper size of the sheet. Explicitly setting the extent limits overrides the default limits. |
federationGuid | undefined | GuidString | ElementState | A FederationGuid assigned to this element by some other federated database |
id | Id64String | EntityState | The Id of this Entity. |
iModel | IModelConnection | EntityState | The iModel from which this Entity was loaded |
isPrivate | undefined | false | true | ViewState | |
jsonProperties | [key: string]: any | EntityState | Optional json properties of this Entity. |
model | Id64String | ElementState | The ModelId of the Model containing this element |
name Accessor ReadOnly | string | ViewState | Get the name of the ViewDefinition from which this ViewState originated. |
parent | undefined | RelatedElement | ElementState | The parent Element of this, or undefined if no parent. |
schemaName Accessor StaticReadOnly | string | EntityState | The name of the BIS schema for this class. |
userLabel | undefined | string | ElementState | A user-assigned label for this element. |
viewFlags Accessor ReadOnly | ViewFlags | ViewState | Get the ViewFlags from the DisplayStyleState of this ViewState. |
Defined in
- core/frontend/src/ViewState.ts Line 1784
Last Updated: 13 June, 2024