register MethodStatic

static function to register the StandardStatusbarItemsProvider

register(providerId: string, defaultItems?: DefaultStatusbarItems, isSupportedStage?: (stageId: string, stageUsage: string, stageAppData?: any) => boolean): StandardStatusbarItemsProvider

Parameter Type Description
providerId string unique identifier for this instance of the provider. This is required in case separate packages want
to set up custom stage with their own subset of standard status bar items.
defaultItems DefaultStatusbarItems if undefined all available item are provided to stage except for activityCenter. If defined only those
specific tool buttons are shown.
isSupportedStage (stageId: string, stageUsage: string, stageAppData?: any) => boolean optional function that will be called to determine if tools should be added to current stage. If not set and
the current stage's usage is set to StageUsage.General then the provider will add items to frontstage.

Returns - StandardStatusbarItemsProvider

Defined in

Last Updated: 05 April, 2024