getAspects Method

Get the ElementAspect instances that are owned by the specified element.

getAspects(elementId: string, aspectClassFullName?: string, excludedClassFullNames?: Set<string>): ElementAspect[]

@throws IModelError

Parameter Type Description
elementId string Get ElementAspects associated with this Element
aspectClassFullName string Optionally filter ElementAspects polymorphically by this class name
excludedClassFullNames Set<string> Optional filter to exclude aspects from classes in the given set.

Returns - ElementAspect[]

Defined in

Last Updated: 16 April, 2024