WorkspaceContainer.Props Interface

Properties that specify a WorkspaceContainer.

Extends

Properties

Name Type Description
syncOnConnect undefined | boolean attempt to synchronize (i.e.  

Inherited properties

Name Type Inherited from Description
accessToken undefined | string Optional SAS token that grants access to the container.
alias undefined | string Optional an alias for the container.
baseUri string Optional The base URI for the container.
containerId string Optional The name of the container.
isPublic undefined | boolean Optional true if the container is public (doesn't require authorization)
lockExpireSeconds undefined | number Optional Duration for holding write lock, in seconds.
logId undefined | string Optional string attached to log messages from CloudSQLite.
secure undefined | boolean Optional if true, container is attached in "secure" mode (blocks are encrypted).
storageType "azure" | "google" Optional The type of storage provider.
tokenRefreshSeconds undefined | number Optional number of seconds between auto-refresh of access token.
writeable undefined | boolean Optional if true, container is allowed to request the write lock.

Defined in

Last Updated: 16 April, 2024