getSchemaInfo Method

Gets the schema info which matches the provided SchemaKey. The schema info may be returned before the schema is fully loaded. May return the entire Schema so long as it is completely loaded as it satisfies the SchemaInfo interface.

getSchemaInfo(schemaKey: Readonly<SchemaKey>, matchType: SchemaMatchType, context: SchemaContext): Promise<undefined | SchemaInfo>

Parameter Type Description
schemaKey Readonly<SchemaKey> The SchemaKey describing the schema to get from the cache.
matchType SchemaMatchType The match type to use when locating the schema
context SchemaContext  

Returns - Promise<undefined | SchemaInfo>

Defined in

Last Updated: 16 April, 2024