register Method

Register a Tool class. This establishes a connection between the toolId of the class and the class itself.

register(toolClass: undefined, namespace?: string): void

Parameter Type Description
toolClass undefined the subclass of Tool to register.
namespace string the namespace for the localized strings for this tool. If undefined, use namespace from superclass.

Returns - void

Defined in

Last Updated: 16 April, 2024